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Preface
With Update 5 for iWork ’09, Pages gets the ability to export word processing documents  in 

the ePub format that is  used by iBooks  on iPad, iPhone, and other platforms. If you have iWork 
’09, download the free update from Software Update in the Apple menu. (It has been available 
there since August 26, 2010.)

Now it is possible to export word processing documents from Pages to any of  these formats:

• Pages

• PDF

• ePub

• Word

• RTF

• Plain text

This document shows you:

• how to create a document using Pages and ePub

• how to move ePub documents to your iTunes Books library and, from there, to your devices. If 
you post the document on the web or email it to your friends, they, too, can follow these steps to 
move it to their iTunes Books libraries.

For more information, see my iWork book, iWork ’09 for Dummies. It covers the techniques 
required to create Pages  documents that can be converted to ePub format. The sections in the 
book on managing styles and using the inspector are particularly important as  you work with 
documents that will be exported to ePub: those general steps are not duplicated here.

This  document is based on Apple’s document, “ePub Best Practices for Pages” which is 
available online at http://images.apple.com/support/pages/docs/ePub_Best_Practices_EN.zip 
and the technical note at http://support.apple.com/kb/HT4168. 

The illustrations  are designed to show you the general layout of the Pages  interface. The best 
way to see the finer details  is to follow the steps in this book and use Pages. Check that you’re in 
the right place by comparing the illustration with the larger image on your computer screen. The 
Pages version of this document will let you enlarge the pages to see much more detail at the 
expense of  having to scroll around.

DOWNLOAD THE EXAMPLES
You can download this  document from northcountryconsulting.com. You do have to register 

and log in to see the downloads (they’re at the left of the main page). Don’t worry, we don’t share 
your email address with others. The download link lets  you download this  document in Pages, 

http://images.apple.com/support/pages/docs/ePub_Best_Practices_EN.zip
http://images.apple.com/support/pages/docs/ePub_Best_Practices_EN.zip
http://support.apple.com/kb/HT4168
http://support.apple.com/kb/HT4168
http://northcountryconsulting.com
http://northcountryconsulting.com


PDF, or ePub formats  so that you can compare the appearance of them. It also lets you 
download Charles  Dickens’s The Pickwick Papers. The process of converting this  from plain text to 
styled text in Pages is  described in iWork ’09 for Dummies. You can download the plain text, styled 
text in Pages, a PDF version, and an ePub version from the website. (Note that the styled version 
is different from that used in the book because it illustrates some features of  ePub.)

CONVENTIONS USED IN THIS BOOK
Macintosh computers run the Mac OS X operating system. (Intel-based Macs  — the only 

ones  made today — can also run Windows.) The iPhone originally ran the iPhone OS operating 
system; it is  derived from the same roots  as  Mac OS X and, in fact, in many ways quite similar. If 
you know how to program Mac OS X, you already know the concepts of iPhone OS and a great 
deal of  the details.

When iPad was released, it, too, ran the iPhone OS. Things started to get a little confusing, 
and so iPhone OS was renamed iOS. It’s  the same software, but it’s  now specifically targeted to 
this  new (and expanding) class  of devices. Instead of enumerating each of these devices, I often 
refer to them generally as iOS devices.

In all of the iWork applications  (Keynote, Numbers, and Pages), you can insert shapes, tables, 
charts, and text boxes. These all behave the same way (most of this  is described in Chapter 8 of 
iWork ’09 for Dummies, “Using Text Boxes”) with regard to their position on the page or within a 
text flow. They are referred to as embedded objects.

—Jesse Feiler



Chapter 1

Taking a look at iBooks and 

ePub
Like all of the iWork programs, Pages plays  well with other programs, platforms and 

operating systems. You can share your work using 

• standard formats such as the Microsoft Office formats for Word, Excel, and Powerpoint; RTF, 
and plain text

• iWork.com where you can share work and let friends and colleagues  annotate it and download 
the iWork files

• the iWork for iPad apps

• PDF which lets  you export a page-by-page image of what would be printed from your iWork 
document.

When Apple launched iPad in April 2010, they launched iBooks at the same time. This app 
for iOS devices (iPad, iPhone, and iPod touch...so far) lets you purchase, view, and annotate books 
from the iBooks store. These books  are created using the ePub format. ePub is a free and open 
format from International Digital Publishing Forum (IDPF); it is  implemented in a variety of 
browsers and in readers such as the Barnes & Noble Nook and the Sony Reader.

UNDERSTANDING THE FORMATS
You use File->Export to create a new file from your Pages  document that can be read using 

other programs. RTF (Rich Text Format), plain text, and Microsoft Word formats can be read 
and edited by many applications including Microsoft Word, Google Docs, and others. If you 
want to export a document so that people can view or print it with a wide range of software, PDF 
and ePub are the best choices. Not only can they be read by many applications, but they do not 
allow editing: this  is a plus  when you are distributing a document and you don’t want people 
modifying it.

If you want to create a copy of your Pages document in Pages format, use File->Save As and 
supply a new name. You don’t use File->Export when you’re going to retain the Pages format.

Here’s a summary of  the important points about each format.

Pages
When you create and save a document in Pages, you (or anyone you share it with) can read it 

and edit it using Pages. Pages lets you create two types of  documents:



• Word Processing documents

• Page Layout documents

Both types can be formatted as  you wish, both can be printed, and both can contain text, 
images, charts, and tables. The difference between them is that in a page layout document, you 
place elements (text boxes, images, charts, and tables) where you want them to appear on each 
page. If text is  too big to be shown in a single text box on a single page, you can link text boxes 
together so that the text flows from one text box to another, and then, possibly to another. (These 
can be on the same or different pages.)

In a word processing document, you just type (or paste) your text. If it is longer than the 
current page, Pages  automatically creates  a new page and continues with the text as you type on 
the new page. You have a certain amount of control over pagination in that you can use the 
Insert menu to create a page break so that Pages will create a new page at that point. You can 
control where the text appears on the page to a limited extent by changing the margins  with the 
Document inspector. If you add images, graphs, or charts to the document, you can use the 
Wrap inspector to specify if they should remain in a specific place on the page or if they should 
be linked to the text. For example, if you refer to an image saying, “In the photo to the right...”, 
that image should always  appear next to that sentence. This  is  called inline placement, and it’s 
described in the section on creating a Pages  document for ePub (and in the book). You can also 
use floating placement in which the image appears  in the same place on the page no matter how 
much text is  added or deleted to the page. This is appropriate for an image such as a logo that 
you always want to have in the same place.

When you want to export a Pages document to ePub, you should start with a word processing 
document: you can’t export page layout documents.

PDF
You may ask, “Why bother?” PDF is  a widely supported format. Most Internet users can read 

PDF documents: some browsers such as  Safari, automatically have code that reads, displays, and 
(subject to user settings) prints  PDF files. If someone doesn’t have that code available, they can 
download Adobe Reader from adobe.com for free. It’s available for Mac OS X, Windows, 
UNIX, and mobile platforms  such as  Android, Pocket PC, Palm OS, and Symbian OS. (Because 
it’s built into Safari, it’s  automatically available on the iOS devices  such as iPhone, iPad, and iPod 
touch.)

PDF files store an image of the document as  it will appear when printed. When you create a 
PDF file, the program you’re using goes through the process of printing the document. That 
means that it respects page breaks  and margins, and in the case of elements  such as charts, tables, 
and images, it  places them as you have specified. When the image is  complete, instead of sending 
it to a printer, it takes the ready-to-print image and stores  it in PDF format in a file. Once that file 
is  written, the margins, page breaks, and inserted elements remain as  they have been written to 
the file.



For example, here’s 
what a page from 
the Pages ’09 User 
Guide looks like in 
PDF format. Here it 
is  on an iPad. Like 
all the images in this 
book, this  one has 
been resized.

(This  is a screenshot 
from an iPad: you 
capture the screen 
i m a g e b y 
s i m u l t a n e o u s l y 
pressing the On/
Off/Wake button at 
the top right and the 
Home button. You’ll 
hear a click, and the 
image is stored in 
your photo album. 
You can then send it 
via email to anyone 
you choose. If you’re 
creating a document 
on your Mac using 
Pages, email it to 
yourself and then 
p l a c e i t i n t h e 
document.)



Now, take a look at the same PDF file as shown on an iPhone. 
It’s the same image that you see on an iPad although the top and 
bottom of the images contain viewing controls (such as  the page 
numbers at the bottom on the iPad version) that are not part of 
the PDF file. What’s  important to note is  that it’s the same page. 
You may not be able to read the text because it’s  so small, but 
you can see from the title and chapter number, that it’s the same 
page and the same layout. If you rotate your iPad or iPhone, 
you’ll see that the image rotates  appropriately but remains the 
same.

If the page is not readable, you can enlarge it by spreading 
your fingers across the screen as  you enlarge any image on an 
iOS device.

ePub
PDF files are created by the programming using its  printing code and then storing the image 

in a file rather than sending it to a printer, but ePub files  use a different methodology. The ePub 
file that is created contains the content of the document as well as  formatting instructions. It is 
not a page image. For that reason, ePub documents  can adapt to different size screens (this is 
particularly important on mobile devices with small and different-size screens).

Pickwick Papers is  used as  an example of formatting in iWork ’09 for Dummies. It’s  used here as a 
demonstration of ePub. (You can download all of the versions  as described in the Preface.) Here’s 
how a page from it appears in the ePub version when shown on an iPad.





 Now, take a look at the same content when shown on an iPhone. Although the text is  small in 
both images  (and both images have been resized in different amounts for readability), you can 
easily see that the chapter title has  adjusted to the different size of the two screens. In addition, 

the lines of  text have wrapped differently depending on the screen.

This  is what a format such as ePub does: it takes  the specified formatting and applies it to the 
device used for display rather than showing a static page image on whatever device you’re using. 
This makes for easier reading and allows a number of  other features to be implemented.

If you download and experiment with the ePub files, you’ll see that on iPad, the image shown 
is page 101; on iPhone it is  page 278. Both pages show the beginning of Chapter VIII, but the 
actual page numbers are generated as  the ePub file is  displayed on the specific device. The reason 
it’s possible to go to the same place on both books is that this page is  the start of a chapter, and 
therefore it begins  on a new page (although it’s  a different page). You’ll see how to manage this in 
the chapter on creating a Pages document for ePub. You’ll also see that the table of contents is 
automatically generated, and these changing page numbers are displayed appropriately there.

LOOKING AT IBOOKS
Books is an app that’s  available for and distributed with iOS 4, so you probably have it on 

your iPhone, iPad or iPod touch. If not, you can buy it (for free) from the App Store. (All apps in 



the app store are purchased. The process of requesting, downloading and installing the app 
requires  you to have an iTunes ID. Many of the apps are free, but the entire process  is  still 
referred to as buying.)

Using iBooks Controls
There are two basic displays  in iBooks. In the previous section, you saw iBooks in action. At 

the top of each page you may see controls  as  those images demonstrate. (You show or hide them 
by tapping in the center of  the page.) 

From left to right, here’s what the controls  do. At the left, the Library button takes  you to the 
library containing all of  your books and PDFs (it’s described in the next section).

Next, the button with three horizontal lines takes  you to the table of contents and your 
bookmarks  as you see here. As noted previously, these page numbers  are generated by iBooks  as it 
processes the ePub file so they are not necessarily the same as you move from device to device.



In addition, you can tap any chapter title to immediately go to it. Furthermore, you can 
control what appears in the table of contents. It is  built using the styles that are described in 
Chapter 9 of iWork ’09 for Dummies. (There are modified styles for ePub documents.) Thus, by 
simply modifying the styles, you can show or hide chapter titles, subsections, and so forth.

Where the second button was, you now have a Resume button: it takes  you back to the page 
you were looking at when you tapped that button with the three horizontal lines.



At the right side of the top of the page, you have four formatting controls. The first lets  you 
adjust the screen brightness, the second lets you adjust the font size, the third brings  up a search 
box, and the last one lets you bookmark a page.

Along with bookmarks, you can add highlights  and notes  to your copy of the book. These are 
stored by iBooks in the appropriate place in the file but you can’t modify the basic content of the 
file itself.

At the bottom of text pages (see the two images as the beginning of the ePub section), a row 
of dots helps you navigate the book. It shows you where you are in the entire book. You can drag 
the slider from the current location to go forward or back. As you drag it, you’ll see the current 
section title (if  any) as well as the page number that you’re on.

Using the Library
The Library button at the top left of most iBooks pages takes you to your library of books. At 

the left, the Store button takes you to the iBooks store where you can buy more books. You can 
also add your own books using iTunes  subject to their digital rights  management (discussed later 
in this chapter).



Next to the Store button, a pair of buttons  let you select books or PDFs. Because they behave 
differently, they’re shown in separate sections of  the library.

At the right, two buttons let you switch between this view and view in which the books or 
PDFs  are shown in a list. The Edit button at the top right lets  you edit either of those two views. 
In the case of the view shown here, you can drag any book or PDF to a new location. A small X 
in the upper left of  each book or PDF lets you delete it from your device.

In the case of the list view, you can delete items, but you can’t rearrange them because the list 
is  alphabetical within genres. In the book world people often refer to categories when describing 
books, but because the data structure here is  the iTunes  structure and it started with music which 
is categorized by genre, books also use the word genre in iTunes.

Tap a book cover to begin reading it where you left off the last time you read it or to start on 
the first page if  you haven’t opened it before.

MANAGING DIGITAL RIGHTS



One of the issues  that has  bedeviled the ebook publishing business from its  very beginning is 
the fact that once a digital version of a book exists, it can easily be transferred from one user to 
another. The work of the publisher and author can wind up being shared widely which is  a good 
thing in some cases, but in other cases, would put publishers  and authors  out of business. The 
same issue applies to music, movies, and all other digitized data.

The ePub specification includes digital rights management (DRM), which is  the software used 
to control authorized and prevent unauthorized copy of the content. ePub specifies how DRM 
fits  into its structure, but it does not require DRM and it does not specify a particular DRM 
system. That is why an ePub file designed for one device can be transferred to another ePub 
device but may not be readable on that device.

Books that are sold in the iBooks store have DRM encoded in them, and they are playable 
only on the iOS devices with valid authentication (that is, you’ve purchased them). However, 
because iBooks  uses ePub, it can let you read non-DRM-encoded ePub files, and it’s those files 
that Pages lets you create.



Chapter 2

Creating a Pages Document for 

ePub
Whether you’re creating your own Pages document from scratch for an ePub book or are 

modifying an existing one, the techniques are simple. They rely on two basic elements of  Pages:

• styles and tables of  contents

• Wrap inspector

The only ePub-specific interface element you need to worry about is  File->Export and the 
ePub option (discussed later in this  chapter). There’s more going on behind the scenes, but you 
don’t have to worry about it.

Styles, tables of contents, and the Wrap inspector are basic iWork features; you may want to 
slightly modify some of the settings as  described in this  chapter, but there are no new concepts 
involved.

The fact that your ePub document will be displayed dynamically on whatever device is in use 
means that you cannot do the same kind of checking that you do with a PDF file. In that case, 
you can produce the PDF file and display it on any device or print it on any printer: it  should 
appear the same in all cases  because that’s the goal. (There are some obvious  exceptions: printing 
a PDF file that uses  color on a black-and-white printer will look different from a screen or color 
printer.)

Because you can’t proofread and check the final result, it’s  important to check the issues  that 
may affect the final result. There’s really only one way of doing this  if your destination is a 
mobile device with a small screen such as iPhone or iPod touch and even a mobile device with a 
larger screen such as  iPad. What you should do is  to prepare the first draft of your Pages 
document (maybe just the first few pages), export an ePub file, and then deploy it to the type of 
device you’ll be using.

STARTING OUT
The basics were described in Chapter 1:

1. Create or open a word processing (not page layout) Pages document.

2. Enter and edit your text.

3. Use File->Export and the ePub option to create the file. (You’ll see the few details of this later 
in the chapter.



At that point, you can add it to your Books in iTunes  and it can automatically be 
synchronized with your iPad, iPod touch, or iPhone (that’s also described in this  chapter in some 
detail). You can also email the ePub document to friends or post it on a website for downloading.

Depending on the document, you may want to add some steps to the process.

A text-only document generally can be exported to ePub and successfully viewed on any ePub 
reader including the iOS devices. You can apply special formatting and you can embed objects 
(shapes, charts, tables, images, and text boxes) and they will be exported appropriately. However, 
you should consider some points that can affect the final result.

• You can’t use multiple columns.

• Headers and footers are not supported, but page numbers are generated automatically. 
Remember they have little meaning for ePub documents, because the pagination changes with 
each device the file is displayed on..

• If you have a number of embedded objects  in your document, as the ePub document is 
reflowed for different devices, you may wind up with hard to read documents on iPhone.

USING STYLES
The styles used in the Pages  version of this document (downloadable as  described in the 

Preface) are based on the Apple styles for their sample document. You don’t have to use these or 
any other styles. What you do need to do is  to set up the table of contents (in the book, it’s in 
Chapter 11, “Advanced Word Processing Techniques). Because the table of contents  will be 
created automatically from your ePub file, this preparation is particularly important.

For many people, one of the major tasks here is  to remove an existing table of contents that 
has been carefully typed out. When the table of contents is created automatically, you don’t have 
to worry about changing page numbers  as you add and subtract pages, but you do have to set it 
up properly.



The key element here is  the TOC tab of the Document 
inspector. Select the paragraph styles  that you want to appear in 
the table of contents. You don’t select page numbers  as a style; 
rather, you use the checkboxes under #s at the right to indicate if 
that particular style should also have a page number.

If you’re planning to export the document to an iOS device 
(and in many other cases as well), remember to use the option at 
the bottom of the window so that the page numbers  are active 
links. That makes the table of  contents particularly useful.

All of this  won’t do you any good if you don’t use these styles 
or if you use them inappropriately. For some people, this  is the 
hardest part to remember. You can us a basic style such as Body 
throughout your document, and you can format headings, 
chapter names, and so forth so that they look right. However, 
although they have the right font, size, and style, they will still be 
Body style elements, and they won’t appear in the table of 
contents unless  you’ve added Body to the styles to be shown (and 
that creates  a pretty useless  table of contents because it contains 
everything).

This  is  an issue with all word processing software: people 
don’t use the styles  because you can create a document that looks 
just fine without them. However, not using styles  prevents you 
from using features  such as automatic table of contents creation in 
most of  these programs.

PLACING IMAGES, CHARTS, SHAPES, AND TABLES
This is described in Chapter 8. Here’s an overview.



1. Insert the object. You can do this  by dragging it into the document or 
by using the Insert menu and selecting the appropriate object. I find it 
easier to use the Insert menu command, because the link to the object 
will be placed exactly at that place. Remember that the object may 
wind up on the next or previous  page. Don’t try to find it or move it 
yet.

2.The inserted object will be 
selected. Open the Wrap inspector. 
and choose Inline, the Object causes 
wrap checkbox, and the type of 
wrapping you want. The Text fit 
settings can be changed later.

3. Once these three setting have 
been made, the embedded object 
should be visible, and you can resize 
it. The best way is by using the 
lower right corner.

 If you want to adjust text fit be careful about fitting the 
text too closely. Remember you are setting up the 
formatting instructions for the ePub file. If you need very 

precise positioning, you may need a page layout document rather than a word processing 
document, and remember that page layout documents can’t be converted to ePub.

EXPORTING THE EPUB FILE
Export the ePub file as soon as  you can — even before the Pages document isn’t finished. You 

want to export it and try it on the target device as soon as  possible so that you can go back and 
change settings if you have to. Pretty soon, you’ll be able to look at the Pages document and 
pinpoint areas that may be problematic when you export the file and try it on an iOS device.

1. Save your Pages  document. The export command doesn’t change the Pages file itself, but you 
should not leave the file unsaved.



2.  Choose File -> Export and select the ePub 
button at the top right of  the window.

3.  Fill in the title and author; choose the genre 
as  well. This information will appear in the 
user’s library.

4. The Next button takes you to a standard save 
dialog. Locate the folder for the new file and 
provide a name. If you will be sharing the file 
with friends  via email or the web, it’s  probably 
safest to not hide the extension (.epub) with the 
checkbox at the bottom left.

5. There may be some warning about the 
export. Just because there are warnings doesn’t 

mean the export failed. Read the warnings and 
you’ll be able to see things that don’t 
convert to ePub.

6.  You can now distribute the file. The 
installation instructions are in the 
following chapter.



Chapter 3

Adding an ePub Book or PDF 

to your iBooks Library
You add an ePub book file to your iTunes library (on a Mac or PC). From there, you 

download it to your iPhone, iPad, or iPod touch the next time you synchronize. Note that this is 
the synchronization that’s  performed when you connect your device with a cable to your Mac or 
PC. Certain data such as  calendars, addresses, and mail may be synchronized over the air so you 
may have gotten out of the habit of synchronizing with a cable. That’s the only route available 
for content that comes  through your computer. Purchases made on your device from the iTunes 
store (including purchases of apps) can be downloaded over your Internet connection directly to 
your device. Files that you receive from friends or that you create yourself never go through the 
iTunes store.

Here are the steps.

1. Open iTunes.

2. Drag the file from your desktop or folder to the iTunes window. Position it over the Library 
section. The entire section will be highlighted. Don’t worry: the file type (epub) will let iTunes 
put your document into the Books  folder in the library. You can also use the File ->Add to 
Library command to select the file.



3. Connect your device. iTunes  may open automatically. If it does not, launch it by double-
clicking the iTunes icon.

4. When you connect the device, a sync may start automatically if it does, just wait until it’s 
finished.

5. In iTunes, select the device in the Devices section at the left of the window. Click the Books 
tab. Choose to sync selected or all books. If you have chosen select books, you’ll see all of the 
books  in your iTunes  Books library on your computer, and you can select those you want to 
synchronize. From now on, they will be synchronized automatically. For the first time, you 
may need to click the Sync button in the lower right of the window. If nothing happens, don’t 
worry. The sync process  is so fast you may miss  it. (There are notices in the status pane at the 
top of  the iTunes window but they can go by quickly.)



If  you already have the document in your library, it is safest to remove the older version.


